New course registrations slow or incomplete

Resolved
Degraded performance
Started 4 months ago Lasted about 1 hour

Affected

Primary Service
Updates
  • Resolved
    Resolved

    We resolved the issue with the sporadic incomplete registrations, so all pending registrations should now be complete. We're sorry about the inconvenience this morning, and thank you for your patience. If we can help with any questions, please let us know!

  • Investigating
    Update

    Load times are mostly back to normal, but we're still investigating an issue where some new registrations fail to complete or take a long time to do so. We'll continue to share status updates here as we diagnose and resolve the issue.

  • Investigating
    Investigating

    We're experiencing sporadic slow load times and failures to complete new registrations for some paths. We are working to resolve the issue and are sorry about the inconvenience! We'll post status updates here as we diagnose and resolve the issue.